Liking cljdoc? Tell your friends :D

orchard.spec


add-multi-specsclj

(add-multi-specs form)

Walk down a spec form and for every subform that is a multi-spec add its sub specs.

Walk down a spec form and for every subform that is a multi-spec
add its sub specs.
sourceraw docstring

clojure-alpha-spec?clj

True if clojure.alpha.spec is supported, otherwise false.

True if `clojure.alpha.spec` is supported, otherwise false.
sourceraw docstring

clojure-spec-alpha?clj

True if clojure.spec.alpha is supported, otherwise false.

True if `clojure.spec.alpha` is supported, otherwise false.
sourceraw docstring

clojure-spec?clj

True if clojure.spec is supported, otherwise false.

True if `clojure.spec` is supported, otherwise false.
sourceraw docstring

describeclj

(describe s)
source

formclj

(form s)
source

genclj

(gen s)
source

generateclj

(generate s)
source

get-multi-spec-sub-specsclj

(get-multi-spec-sub-specs multi-spec-form)

Given a multi-spec form, call its multi method methods to retrieve its subspecs.

Given a multi-spec form, call its multi method methods to retrieve
its subspecs.
sourceraw docstring

get-specclj

(get-spec k)
source

normalize-spec-fn-formclj

(normalize-spec-fn-form [_ [sym] & r])

Given a form like (fn* [any-symbol] ... any-symbol...) replace fn* with fn and any occurrence of any-symbol with %.

Given a form like (fn* [any-symbol] ... any-symbol...) replace fn* with fn
and any occurrence of any-symbol with %.
sourceraw docstring

normalize-spec-formclj

(normalize-spec-form sub-form)

Applys normalize-spec-fn-form to any fn* sub form.

Applys normalize-spec-fn-form to any fn* sub form.
sourceraw docstring

registryclj

(registry)
source

spec-exampleclj

(spec-example spec-name)

Given a spec symbol as a string, returns a string with a pretty printed example generated by the spec.

Given a spec symbol as a string, returns a string with a pretty printed
example generated by the spec.
sourceraw docstring

spec-formclj

(spec-form spec-name)
(spec-form spec-name ns)

Given a spec symbol as a string, get the spec form and prepare it for a response.

Given a spec symbol as a string, get the spec form and prepare it for
a response.
sourceraw docstring

spec-from-stringclj

(spec-from-string s)

Given a string like "clojure.core/let" or ":user/email" returns the associated spec in the registry, if there is one.

Given a string like "clojure.core/let" or ":user/email" returns
the associated spec in the registry, if there is one.
sourceraw docstring

spec-listclj

(spec-list filter-regex)
(spec-list filter-regex ns)

Retrieves a list of all specs in the registry, sorted by ns/name. If filter-regex is not empty, keep only the specs with that prefix.

Retrieves a list of all specs in the registry, sorted by ns/name.
If filter-regex is not empty, keep only the specs with that prefix.
sourceraw docstring

spec?clj

True if clojure.spec, clojure.spec.alpha orclojure.alpha.spec is supported, otherwise false.

True if `clojure.spec`, `clojure.spec.alpha` or`clojure.alpha.spec` is supported, otherwise false.
sourceraw docstring

str-non-collsclj

(str-non-colls form)

Given a form, convert all non collection childs to str.

Given a form, convert all non collection childs to str.
sourceraw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close