(add-multi-specs form)
Walk down a spec form and for every subform that is a multi-spec add its sub specs.
Walk down a spec form and for every subform that is a multi-spec add its sub specs.
True if clojure.alpha.spec
is supported, otherwise false.
True if `clojure.alpha.spec` is supported, otherwise false.
True if clojure.spec.alpha
is supported, otherwise false.
True if `clojure.spec.alpha` is supported, otherwise false.
(get-multi-spec-sub-specs multi-spec-form)
Given a multi-spec form, call its multi method methods to retrieve its subspecs.
Given a multi-spec form, call its multi method methods to retrieve its subspecs.
(normalize-spec-fn-form [_ [sym] & r])
Given a form like (fn* [any-symbol] ... any-symbol...) replace fn* with fn and any occurrence of any-symbol with %.
Given a form like (fn* [any-symbol] ... any-symbol...) replace fn* with fn and any occurrence of any-symbol with %.
(normalize-spec-form sub-form)
Applys normalize-spec-fn-form to any fn* sub form.
Applys normalize-spec-fn-form to any fn* sub form.
(spec-example spec-name)
Given a spec symbol as a string, returns a string with a pretty printed example generated by the spec.
Given a spec symbol as a string, returns a string with a pretty printed example generated by the spec.
(spec-form spec-name)
(spec-form spec-name ns)
Given a spec symbol as a string, get the spec form and prepare it for a response.
Given a spec symbol as a string, get the spec form and prepare it for a response.
(spec-from-string s)
Given a string like "clojure.core/let" or ":user/email" returns the associated spec in the registry, if there is one.
Given a string like "clojure.core/let" or ":user/email" returns the associated spec in the registry, if there is one.
(spec-list filter-regex)
(spec-list filter-regex ns)
Retrieves a list of all specs in the registry, sorted by ns/name. If filter-regex is not empty, keep only the specs with that prefix.
Retrieves a list of all specs in the registry, sorted by ns/name. If filter-regex is not empty, keep only the specs with that prefix.
True if clojure.spec.alpha
orclojure.alpha.spec
is supported, otherwise false.
True if `clojure.spec.alpha` or`clojure.alpha.spec` is supported, otherwise false.
(str-non-colls form)
Given a form, convert all non collection childs to str.
Given a form, convert all non collection childs to str.
cljdoc is a website building & hosting documentation for Clojure/Script libraries
× close