Liking cljdoc? Tell your friends :D

hyperfiddle.spec


argclj

(arg ident arg-key)
source

argsclj

(args ident)
source

cardinality-many?clj

(cardinality-many? ident)

Guess the cardinality of a speced function or keyword.

Guess the cardinality of a speced function or keyword.
sourceraw docstring

datafy*clj

(datafy* spec)
source

explain-fspec-dataclj

(explain-fspec-data fspec & args)
source

extend-specclj

(extend-spec spec)
source

formclj

(form spec)
source

get-specclj

(get-spec ident)

Like s/get-spec, but resolve aliases

Like s/get-spec, but resolve aliases
sourceraw docstring

parseclj

(parse form)
source

pred->typeclj

source

reflectclj

(reflect spec-or-ident)
source

reformat-explain-dataclj

(reformat-explain-data ed)
source

renamespaceclj

(renamespace mapping ident)
source

specclj

(spec spec-or-ident)
source

spec-typeclj

(spec-type spec)
source

type-ofclj

(type-of spec)
(type-of spec argument)
source

typesclj

source

valueType->predclj

source

valueType->typeclj

source

valueType-ofclj

(valueType-of schema attr)
source

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close