(check! & args)
Asserts validity, explaining the cause otherwise. Apt for :pre conditions.
Reporting can be controlled by setting nedap.utils.spec.print-symbol
.
args
is a sequence of spec-val pairs.
Asserts validity, explaining the cause otherwise. Apt for :pre conditions. Reporting can be controlled by setting `nedap.utils.spec.print-symbol`. `args` is a sequence of spec-val pairs.
(coerce-map-indicating-invalidity spec m)
Tries to coerce the map m
according to spec spec
.
If the coercion isn't possible, ::invalid? true
is associated to the map.
Tries to coerce the map `m` according to spec `spec`. If the coercion isn't possible, `::invalid? true` is associated to the map.
cljdoc is a website building & hosting documentation for Clojure/Script libraries
× close