Liking cljdoc? Tell your friends :D

fr.jeremyschoffen.mapiform.alpha.clj.spec


dependenciescljmacro

(dependencies sym)

Find the nes of the functions sym depends on.

Find the nes of the functions `sym` depends on.
sourceraw docstring

get-reportclj

(get-report sym)
source

param-suggestionscljmacro

(param-suggestions sym)

Search the dependencies specs of the function named sym to find all the potential parameters the function may require.

Search the dependencies specs of the function named `sym` to
find all the potential parameters the function may require.
sourceraw docstring

param-usersclj

(param-users kw)

Return a set of all functions depending on the keyword kw.

Return a set of all functions depending on the keyword `kw`.
sourceraw docstring

reportcljmacro

(report sym)

Get spec data for sym.

Get spec data for `sym`.
sourceraw docstring

speccljmacro

(spec sym)

Get the spec of the function named sym and the specs of its dependencies.

Get the spec of the function named `sym` and the specs of its dependencies.
sourceraw docstring

spec-opcljmacro

(spec-op name & {:keys [deps param fn ret]})

Declare a spec for a one arg map function.

Declare a spec for a one arg map function.
sourceraw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close