Liking cljdoc? Tell your friends :D

gradual.spec


>seq-destructuring-specclj/s

(>seq-destructuring-spec positional-destructurer
                         most-complex-positional-destructurer
                         kv-spec
                         or|conformer
                         seq-spec
                         {:as opts generate-from-seq-spec? :gen?})

Creates a spec that performs seq destructuring, and provides a default generator for such based on the generators of the destructured args.

Creates a spec that performs seq destructuring, and provides a default generator for such based
on the generators of the destructured args.
sourceraw docstring

arglist>spec-form|arglistclj/s

(arglist>spec-form|arglist args+varargs kw-args)
source

defncljmacro

(defn & args)

Like gradual.type/defn, but relies entirely on runtime spec checks. Ignores type inference requests, but allows them for compatibility with gradual.type/defn.

Like `gradual.type/defn`, but relies entirely on runtime spec checks. Ignores type inference
requests, but allows them for compatibility with `gradual.type/defn`.
sourceraw docstring

defn-cljmacro

(defn- & args)

defn : defn- :: core/defn : core/defn-

defn : defn- :: core/defn : core/defn-
sourceraw docstring

fncljmacro

(fn & args)

Like gradual.type/fn, but relies entirely on runtime spec checks. Ignores type inference requests, but allows them for compatibility with gradual.type/defn.

Like `gradual.type/fn`, but relies entirely on runtime spec checks. Ignores type inference
requests, but allows them for compatibility with `gradual.type/defn`.
sourceraw docstring

fn|codeclj/s

(fn|code kind lang args)
source

map-destructurecljmacro

(map-destructure map-spec kv-specs)
source

seq-destructurecljmacro

(seq-destructure seq-spec args & [varargs])

If generate-from-seq-spec? is true, generates from seq-spec's generator instead of the default generation strategy based on the generators of the destructured args.

If `generate-from-seq-spec?` is true, generates from `seq-spec`'s generator instead of the
default generation strategy based on the generators of the destructured args.
sourceraw docstring

speced-binding>arg-identclj/s

(speced-binding>arg-ident {[kind binding-] :binding-form} & [i|arg])
source

speced-binding>bindingclj/s

(speced-binding>binding {[kind binding-] :binding-form})
source

speced-binding>specclj/s

(speced-binding>spec
  {:as speced-binding [kind binding-] :binding-form [spec-kind spec] :spec})
source

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close