Tools for simplifying spec usage.
Tools for simplifying spec usage.
(conform spec data)
Conform data to spec or throw explained data.
Conform data to spec or throw explained data.
(specs->dict specs)
(tagged->value tagged)
Convert tagged value to vector or identity without a tag.
Convert tagged value to vector or identity without a tag.
(valid? spec data)
Check if data valid for spec and return the data or throw explained exception.
Check if data valid for spec and return the data or throw explained exception.
(validate-strict-keys spec)
Return fn to validate strict keys for given spec.
Return fn to validate strict keys for given spec.
cljdoc is a website building & hosting documentation for Clojure/Script libraries
× close