Liking cljdoc? Tell your friends :D

automigrate.util.spec

Tools for simplifying spec usage.

Tools for simplifying spec usage.
raw docstring

conformclj

(conform spec data)

Conform data to spec or throw explained data.

Conform data to spec or throw explained data.
raw docstring

specs->dictclj

(specs->dict specs)

tagged->valueclj

(tagged->value tagged)

Convert tagged value to vector or identity without a tag.

Convert tagged value to vector or identity without a tag.
raw docstring

valid?clj

(valid? spec data)

Check if data valid for spec and return the data or throw explained exception.

Check if data valid for spec and return the data or throw explained exception.
raw docstring

validate-strict-keysclj

(validate-strict-keys spec)

Return fn to validate strict keys for given spec.

Return fn to validate strict keys for given spec.
raw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close