Tools for simplifying spec usage.
Tools for simplifying spec usage.
(assert! spec value)
Check value against spec, throw detailed exception if it failed otherwise return true.
Based on clojure.spec.alpha/assert*: https://github.com/clojure/spec.alpha/blob/13bf36628eb02904155d0bf0d140f591783c51af/src/main/clojure/clojure/spec/alpha.clj#L1966-L1975
Check value against spec, throw detailed exception if it failed otherwise return true. Based on clojure.spec.alpha/assert*: https://github.com/clojure/spec.alpha/blob/13bf36628eb02904155d0bf0d140f591783c51af/src/main/clojure/clojure/spec/alpha.clj#L1966-L1975
(conform spec data)
Conform data to spec or throw explained data.
Conform data to spec or throw explained data.
(valid? spec data)
Check if data valid for spec and return the data or throw explained exception.
Check if data valid for spec and return the data or throw explained exception.
(validate-strict-keys spec)
Return fn to validate strict keys for given spec.
Return fn to validate strict keys for given spec.
cljdoc is a website building & hosting documentation for Clojure/Script libraries
× close