Liking cljdoc? Tell your friends :D

org.purefn.kurosawa.spec


defcljmacro

(def name & attr)

Registers a spec with optional given docstring. Also calls out clojure's spec registry to register the spec, if name is registerable.

Registers a spec with optional given docstring. Also calls out
clojure's spec registry to register the spec, if name is
registerable.
sourceraw docstring

docclj

(doc name)

Returns the docstring for a given spec name.

Returns the docstring for a given spec name.
sourceraw docstring

get-specclj

(get-spec name)

Wraps Clojure spec's lookup function, but the returned spec will have the docstring as metadata.

Wraps Clojure spec's lookup function, but the returned spec will have
the docstring as metadata.
sourceraw docstring

namespace-specsclj

(namespace-specs ns)

Returns a collection of all the specs for a given namespace - in other words, the specs that have keyword names and the keyword is in the given namespace. Each will have their docstring as metadata.

Returns a collection of all the specs for a given namespace - in
other words, the specs that have keyword names and the keyword is
in the given namespace. Each will have their docstring as
metadata.
sourceraw docstring

registerclj

(register name doc)

Do not call this directly, use def

Do not call this directly, use `def`
sourceraw docstring

registryclj

(registry)

Returns the registry map, keyed by spec name, with documentation metadata on each spec.

Returns the registry map, keyed by spec name, with documentation metadata
on each spec.
sourceraw docstring

with-docclj

(with-doc name)
(with-doc name spec)

For given spec name, looks up spec (or uses provided) and, if docstring is available for that name, returns spec with the docstring as :doc metadata.

For given spec name, looks up spec (or uses provided) and, if
docstring is available for that name, returns spec with the
docstring as `:doc` metadata.
sourceraw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close