Liking cljdoc? Tell your friends :D

tla-edn.spec


classes-loaded?clj

(classes-loaded?)

classes-to-be-loadedclj


compile-operatorsclj

(compile-operators ns)

ns is a symbol (e.g 'my-ns.core). Does not compile if all classes are already loaded.

`ns` is a symbol (e.g 'my-ns.core).
Does not compile if all classes are already loaded.
raw docstring

defopcljmacro

(defop
  name
  {:keys [:module :identifier :warn :prefix] :or {warn true prefix ""} :as opts}
  doc-string?
  attr-map?
  [params*]
  prepost-map?
  body)

Generates a class and a function which should be used to override a TLA+ operator.

Generates a class and a function which should be used to override
a TLA+ operator.
raw docstring

run-specclj

(run-spec model-path cfg-path)
(run-spec model-path cfg-path cli-opts)

This should be run from a fresh JVM as the TLA+ model checker is not stable after first run (there is no known way to reset it without to restart the JVM).

This should be run from a fresh JVM as the TLA+ model checker is
not stable after first run (there is no known way to reset it without
to restart the JVM).
raw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close