Liking cljdoc? Tell your friends :D

zpst.spec


explain-moreclj

(explain-more explain-data-return)

Try to do a better job of explaining spec problems.

Try to do a better job of explaining spec problems.
sourceraw docstring

ks-phraseclj

(ks-phrase problem)

Take a key-sequence and a value, and decide if we want to call it a value or a key.

Take a key-sequence and a value, and decide if we want to 
call it a value or a key.
sourceraw docstring

map-predclj

(map-pred pred)

Turn some predicates into something more understandable.

Turn some predicates into something more understandable.
sourceraw docstring

map-pred-altclj

(map-pred-alt pred)

Turn some predicates into something more understandable.

Turn some predicates into something more understandable.
sourceraw docstring

numbers-or-number-pred?clj

(numbers-or-number-pred? x y)

If they are both numbers and are equal, or the first is a number and the second one is a pred.

If they are both numbers and are equal, or the first is a number 
and the second one is a pred.
sourceraw docstring

only-keysclj/smacro

(only-keys & {:keys [req req-un opt opt-un] :as args})

Like keys, but checks that only the keys mentioned are allowed. Credit to Alistair Roche, 9/25/16 post in Clojure google group.

Like keys, but checks that only the keys mentioned are allowed. 
Credit to Alistair Roche, 9/25/16 post in Clojure google group.
sourceraw docstring

problem-ksclj

(problem-ks problem)

Return the key sequence for this problem. This is totally empiric, and not based on any real understanding of what explain-data is returning as the problem. It seems to stick integers into the :in for no obvious reason. This version has three heuristics, described in the comments in the code.

Return the key sequence for this problem.  This is totally empiric, and
not based on any real understanding of what explain-data is returning as
the problem.  It seems to stick integers into the :in for no obvious reason.
This version has three heuristics, described in the comments in the code.
sourceraw docstring

validate-basicclj

(validate-basic options)
(validate-basic options source-str)

Using spec defined above, validate the given options map. Return nil if no errors, or a string containing errors if any.

Using spec defined above, validate the given options map.  Return
nil if no errors, or a string containing errors if any.
sourceraw docstring

zany?clj

(zany? x)
source

zboolean?clj

(zboolean? x)
source

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close