Liking cljdoc? Tell your friends :D

jdk.security.spec.AlgorithmParameterSpec

A (transparent) specification of cryptographic parameters.

This interface contains no methods or constants. Its only purpose is to group (and provide type safety for) all parameter specifications. All parameter specifications must implement this interface.

A (transparent) specification of cryptographic parameters.

 This interface contains no methods or constants. Its only purpose
is to group (and provide type safety for) all parameter specifications.
All parameter specifications must implement this interface.
raw docstring

No vars found in this namespace.

jdk.security.spec.core

No vars found in this namespace.

jdk.security.spec.DSAGenParameterSpec

This immutable class specifies the set of parameters used for generating DSA parameters as specified in FIPS 186-3 Digital Signature Standard (DSS).

This immutable class specifies the set of parameters used for
generating DSA parameters as specified in
FIPS 186-3 Digital Signature Standard (DSS).
raw docstring

jdk.security.spec.DSAParameterSpec

This class specifies the set of parameters used with the DSA algorithm.

This class specifies the set of parameters used with the DSA algorithm.
raw docstring

jdk.security.spec.DSAPrivateKeySpec

This class specifies a DSA private key with its associated parameters.

This class specifies a DSA private key with its associated parameters.
raw docstring

jdk.security.spec.DSAPublicKeySpec

This class specifies a DSA public key with its associated parameters.

This class specifies a DSA public key with its associated parameters.
raw docstring

jdk.security.spec.ECField

This interface represents an elliptic curve (EC) finite field. All specialized EC fields must implements this interface.

This interface represents an elliptic curve (EC) finite field.
All specialized EC fields must implements this interface.
raw docstring

jdk.security.spec.ECFieldF2m

This immutable class defines an elliptic curve (EC) characteristic 2 finite field.

This immutable class defines an elliptic curve (EC)
characteristic 2 finite field.
raw docstring

jdk.security.spec.ECFieldFp

This immutable class defines an elliptic curve (EC) prime finite field.

This immutable class defines an elliptic curve (EC) prime
finite field.
raw docstring

jdk.security.spec.ECGenParameterSpec

This immutable class specifies the set of parameters used for generating elliptic curve (EC) domain parameters.

This immutable class specifies the set of parameters used for
generating elliptic curve (EC) domain parameters.
raw docstring

jdk.security.spec.ECParameterSpec

This immutable class specifies the set of domain parameters used with elliptic curve cryptography (ECC).

This immutable class specifies the set of domain parameters
used with elliptic curve cryptography (ECC).
raw docstring

jdk.security.spec.ECPoint

This immutable class represents a point on an elliptic curve (EC) in affine coordinates. Other coordinate systems can extend this class to represent this point in other coordinates.

This immutable class represents a point on an elliptic curve (EC)
in affine coordinates. Other coordinate systems can
extend this class to represent this point in other
coordinates.
raw docstring

jdk.security.spec.ECPrivateKeySpec

This immutable class specifies an elliptic curve private key with its associated parameters.

This immutable class specifies an elliptic curve private key with
its associated parameters.
raw docstring

jdk.security.spec.ECPublicKeySpec

This immutable class specifies an elliptic curve public key with its associated parameters.

This immutable class specifies an elliptic curve public key with
its associated parameters.
raw docstring

jdk.security.spec.EllipticCurve

This immutable class holds the necessary values needed to represent an elliptic curve.

This immutable class holds the necessary values needed to represent
an elliptic curve.
raw docstring

jdk.security.spec.EncodedKeySpec

This class represents a public or private key in encoded format.

This class represents a public or private key in encoded format.
raw docstring

jdk.security.spec.InvalidKeySpecException

This is the exception for invalid key specifications.

This is the exception for invalid key specifications.
raw docstring

jdk.security.spec.InvalidParameterSpecException

This is the exception for invalid parameter specifications.

This is the exception for invalid parameter specifications.
raw docstring

jdk.security.spec.KeySpec

A (transparent) specification of the key material that constitutes a cryptographic key.

If the key is stored on a hardware device, its specification may contain information that helps identify the key on the device.

A key may be specified in an algorithm-specific way, or in an algorithm-independent encoding format (such as ASN.1). For example, a DSA private key may be specified by its components x, p, q, and g (see DSAPrivateKeySpec), or it may be specified using its DER encoding (see PKCS8EncodedKeySpec).

This interface contains no methods or constants. Its only purpose is to group (and provide type safety for) all key specifications. All key specifications must implement this interface.

A (transparent) specification of the key material
that constitutes a cryptographic key.

If the key is stored on a hardware device, its
specification may contain information that helps identify the key on the
device.

 A key may be specified in an algorithm-specific way, or in an
algorithm-independent encoding format (such as ASN.1).
For example, a DSA private key may be specified by its components
x, p, q, and g
(see DSAPrivateKeySpec), or it may be
specified using its DER encoding
(see PKCS8EncodedKeySpec).

 This interface contains no methods or constants. Its only purpose
is to group (and provide type safety for) all key specifications.
All key specifications must implement this interface.
raw docstring

No vars found in this namespace.

jdk.security.spec.MGF1ParameterSpec

This class specifies the set of parameters used with mask generation function MGF1 in OAEP Padding and RSA-PSS signature scheme, as defined in the PKCS #1 v2.1 standard.

Its ASN.1 definition in PKCS#1 standard is described below:

MGF1Parameters ::= OAEP-PSSDigestAlgorthms where

OAEP-PSSDigestAlgorithms ALGORITHM-IDENTIFIER ::= { { OID id-sha1 PARAMETERS NULL }| { OID id-sha224 PARAMETERS NULL }| { OID id-sha256 PARAMETERS NULL }| { OID id-sha384 PARAMETERS NULL }| { OID id-sha512 PARAMETERS NULL }, ... -- Allows for future expansion -- }

This class specifies the set of parameters used with mask generation
function MGF1 in OAEP Padding and RSA-PSS signature scheme, as
defined in the
PKCS #1 v2.1
standard.

Its ASN.1 definition in PKCS#1 standard is described below:


MGF1Parameters ::= OAEP-PSSDigestAlgorthms
where


OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
  { OID id-sha1 PARAMETERS NULL   }|
  { OID id-sha224 PARAMETERS NULL   }|
  { OID id-sha256 PARAMETERS NULL }|
  { OID id-sha384 PARAMETERS NULL }|
  { OID id-sha512 PARAMETERS NULL },
  ...  -- Allows for future expansion --
}
raw docstring

jdk.security.spec.PKCS8EncodedKeySpec

This class represents the ASN.1 encoding of a private key, encoded according to the ASN.1 type PrivateKeyInfo. The PrivateKeyInfo syntax is defined in the PKCS#8 standard as follows:

PrivateKeyInfo ::= SEQUENCE { version Version, privateKeyAlgorithm PrivateKeyAlgorithmIdentifier, privateKey PrivateKey, attributes [0] IMPLICIT Attributes OPTIONAL }

Version ::= INTEGER

PrivateKeyAlgorithmIdentifier ::= AlgorithmIdentifier

PrivateKey ::= OCTET STRING

Attributes ::= SET OF Attribute

This class represents the ASN.1 encoding of a private key,
encoded according to the ASN.1 type PrivateKeyInfo.
The PrivateKeyInfo syntax is defined in the PKCS#8 standard
as follows:



PrivateKeyInfo ::= SEQUENCE {
  version Version,
  privateKeyAlgorithm PrivateKeyAlgorithmIdentifier,
  privateKey PrivateKey,
  attributes [0] IMPLICIT Attributes OPTIONAL }

Version ::= INTEGER

PrivateKeyAlgorithmIdentifier ::= AlgorithmIdentifier

PrivateKey ::= OCTET STRING

Attributes ::= SET OF Attribute
raw docstring

jdk.security.spec.PSSParameterSpec

This class specifies a parameter spec for RSA-PSS signature scheme, as defined in the PKCS#1 v2.1 standard.

Its ASN.1 definition in PKCS#1 standard is described below:

RSASSA-PSS-params ::= SEQUENCE { hashAlgorithm [0] OAEP-PSSDigestAlgorithms DEFAULT sha1, maskGenAlgorithm [1] PKCS1MGFAlgorithms DEFAULT mgf1SHA1, saltLength [2] INTEGER DEFAULT 20, trailerField [3] INTEGER DEFAULT 1 } where

OAEP-PSSDigestAlgorithms ALGORITHM-IDENTIFIER ::= { { OID id-sha1 PARAMETERS NULL }| { OID id-sha224 PARAMETERS NULL }| { OID id-sha256 PARAMETERS NULL }| { OID id-sha384 PARAMETERS NULL }| { OID id-sha512 PARAMETERS NULL }, ... -- Allows for future expansion -- }

PKCS1MGFAlgorithms ALGORITHM-IDENTIFIER ::= { { OID id-mgf1 PARAMETERS OAEP-PSSDigestAlgorithms }, ... -- Allows for future expansion -- } Note: the PSSParameterSpec.DEFAULT uses the following: message digest -- "SHA-1" mask generation function (mgf) -- "MGF1" parameters for mgf -- MGF1ParameterSpec.SHA1 SaltLength -- 20 TrailerField -- 1

This class specifies a parameter spec for RSA-PSS signature scheme,
as defined in the
PKCS#1 v2.1
standard.

Its ASN.1 definition in PKCS#1 standard is described below:


RSASSA-PSS-params ::= SEQUENCE {
  hashAlgorithm      [0] OAEP-PSSDigestAlgorithms  DEFAULT sha1,
  maskGenAlgorithm   [1] PKCS1MGFAlgorithms  DEFAULT mgf1SHA1,
  saltLength         [2] INTEGER  DEFAULT 20,
  trailerField       [3] INTEGER  DEFAULT 1
}
where


OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
  { OID id-sha1 PARAMETERS NULL   }|
  { OID id-sha224 PARAMETERS NULL   }|
  { OID id-sha256 PARAMETERS NULL }|
  { OID id-sha384 PARAMETERS NULL }|
  { OID id-sha512 PARAMETERS NULL },
  ...  -- Allows for future expansion --
}

PKCS1MGFAlgorithms    ALGORITHM-IDENTIFIER ::= {
  { OID id-mgf1 PARAMETERS OAEP-PSSDigestAlgorithms },
  ...  -- Allows for future expansion --
}
Note: the PSSParameterSpec.DEFAULT uses the following:
    message digest  -- "SHA-1"
    mask generation function (mgf) -- "MGF1"
    parameters for mgf -- MGF1ParameterSpec.SHA1
    SaltLength   -- 20
    TrailerField -- 1
raw docstring

jdk.security.spec.RSAKeyGenParameterSpec

This class specifies the set of parameters used to generate an RSA key pair.

This class specifies the set of parameters used to generate an RSA
key pair.
raw docstring

jdk.security.spec.RSAMultiPrimePrivateCrtKeySpec

This class specifies an RSA multi-prime private key, as defined in the PKCS#1 v2.1, using the Chinese Remainder Theorem (CRT) information values for efficiency.

This class specifies an RSA multi-prime private key, as defined in the
PKCS#1 v2.1, using the Chinese Remainder Theorem (CRT) information
values for efficiency.
raw docstring

jdk.security.spec.RSAOtherPrimeInfo

This class represents the triplet (prime, exponent, and coefficient) inside RSA's OtherPrimeInfo structure, as defined in the PKCS#1 v2.1. The ASN.1 syntax of RSA's OtherPrimeInfo is as follows:

OtherPrimeInfo ::= SEQUENCE { prime INTEGER, exponent INTEGER, coefficient INTEGER }

This class represents the triplet (prime, exponent, and coefficient)
inside RSA's OtherPrimeInfo structure, as defined in the PKCS#1 v2.1.
The ASN.1 syntax of RSA's OtherPrimeInfo is as follows:



OtherPrimeInfo ::= SEQUENCE {
  prime INTEGER,
  exponent INTEGER,
  coefficient INTEGER
  }
raw docstring

jdk.security.spec.RSAPrivateCrtKeySpec

This class specifies an RSA private key, as defined in the PKCS#1 standard, using the Chinese Remainder Theorem (CRT) information values for efficiency.

This class specifies an RSA private key, as defined in the PKCS#1
standard, using the Chinese Remainder Theorem (CRT) information values for
efficiency.
raw docstring

jdk.security.spec.RSAPrivateKeySpec

This class specifies an RSA private key.

This class specifies an RSA private key.
raw docstring

jdk.security.spec.RSAPublicKeySpec

This class specifies an RSA public key.

This class specifies an RSA public key.
raw docstring

jdk.security.spec.X509EncodedKeySpec

This class represents the ASN.1 encoding of a public key, encoded according to the ASN.1 type SubjectPublicKeyInfo. The SubjectPublicKeyInfo syntax is defined in the X.509 standard as follows:

SubjectPublicKeyInfo ::= SEQUENCE { algorithm AlgorithmIdentifier, subjectPublicKey BIT STRING }

This class represents the ASN.1 encoding of a public key,
encoded according to the ASN.1 type SubjectPublicKeyInfo.
The SubjectPublicKeyInfo syntax is defined in the X.509
standard as follows:



SubjectPublicKeyInfo ::= SEQUENCE {
  algorithm AlgorithmIdentifier,
  subjectPublicKey BIT STRING }
raw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close