Liking cljdoc? Tell your friends :D

nedap.utils.spec.api


check!clj/smacro

(check! & args)

Asserts validity, explaining the cause otherwise. Apt for :pre conditions.

Reporting can be controlled by setting nedap.utils.spec.print-symbol.

args is a sequence of spec-val pairs.

Asserts validity, explaining the cause otherwise. Apt for :pre conditions.

   Reporting can be controlled by setting `nedap.utils.spec.print-symbol`.

`args` is a sequence of spec-val pairs.
sourceraw docstring

coerce-map-indicating-invalidityclj/s

(coerce-map-indicating-invalidity spec m)

Tries to coerce the map m according to spec spec.

If the coercion isn't possible, ::invalid? true is associated to the map.

Tries to coerce the map `m` according to spec `spec`.

If the coercion isn't possible, `::invalid? true` is associated to the map.
sourceraw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close