Liking cljdoc? Tell your friends :D

cpf-cnpj-spec.cnpj


control-digitsclj/s

source

formatclj/s

(format cnpj)

Returns a string of the correctly formatted cnpj

Returns a string of the correctly formatted cnpj
sourceraw docstring

formatted?clj/s

(formatted? cnpj)

Is the cnpj formatted correctly?

Is the cnpj formatted correctly?
sourceraw docstring

generateclj/s

(generate)
(generate branch)

Generates a random valid cnpj. An integer argument can be given to choose headquarters or a branch. (Matriz ou filial) In a cnpj xx.xxx.xxx/0001-xx, 0001 is the branch number, in this case headquarters.

Generates a random valid cnpj.
An integer argument can be given to choose headquarters or a branch.
(Matriz ou filial)
In a cnpj xx.xxx.xxx/0001-xx, 0001 is the branch number,
in this case headquarters.
sourceraw docstring

generate-formattedclj/s

(generate-formatted)
(generate-formatted branch)

Generates a random valid cnpj. An integer argument can be given to choose headquarters or a branch. (Matriz ou filial) In a cnpj xx.xxx.xxx/0001-xx, 0001 is the branch number, in this case headquarters.

Generates a random valid cnpj.
An integer argument can be given to choose headquarters or a branch.
(Matriz ou filial)
In a cnpj xx.xxx.xxx/0001-xx, 0001 is the branch number,
in this case headquarters.
sourceraw docstring

generate-intclj/s

(generate-int)
(generate-int branch)

Generates a random valid cnpj as a integer, because life sucks

Generates a random valid cnpj as a integer, because life sucks
sourceraw docstring

lengthclj/s

source

regexclj/s

source

repeatedclj/s

A set of cnpjs with repeated digits that are considered valid by the algorithm, but normally shouldn't count as valid.

A set of cnpjs with repeated digits that are
considered valid by the algorithm, but normally shouldn't count as valid.
sourceraw docstring

valid-int?clj/s

(valid-int? cnpj)

Takes a integer and validade it as a cnpj

Takes a integer and validade it as a cnpj
sourceraw docstring

valid?clj/s

(valid? cnpj)

Takes a string. Returns true if valid, else false.

Takes a string. Returns true if valid, else false.
sourceraw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close