Liking cljdoc? Tell your friends :D
Clojure only.

metabase.db.spec

Functions for creating JDBC DB specs for a given engine. Only databases that are supported as application DBs should have functions in this namespace; otherwise, similar functions are only needed by drivers, and belong in those namespaces.

Functions for creating JDBC DB specs for a given engine.
Only databases that are supported as application DBs should have functions in this namespace;
otherwise, similar functions are only needed by drivers, and belong in those namespaces.
raw docstring

h2clj

(h2 {:keys [db] :or {db "h2.db"} :as opts})

Create a Clojure JDBC database specification for a H2 database.

Create a Clojure JDBC database specification for a H2 database.
sourceraw docstring

mysqlclj

(mysql {:keys [host port db] :or {host "localhost" port 3306 db ""} :as opts})

Create a Clojure JDBC database specification for a MySQL or MariaDB database.

Create a Clojure JDBC database specification for a MySQL or MariaDB database.
sourceraw docstring

postgresclj

(postgres
  {:keys [host port db] :or {host "localhost" port 5432 db ""} :as opts})

Create a Clojure JDBC database specification for a Postgres database.

Create a Clojure JDBC database specification for a Postgres database.
sourceraw docstring

cljdoc is a website building & hosting documentation for Clojure/Script libraries

× close